Mercedes Benz CLS 350cdi Grand Edition 2010 [model W219] – windscreen wiper stopped / not working.

I’ll try to keep this one short.

No explanation, passenger / near side (UK RHD) windscreen wiper stops working – driver’s side works as normal.

First temptation – fuses and relays:

Find the manual – turn to page 231 “Fuse Allocation” to find advice to the effect that Fuse Allocation is documented in the fuse box to the driver’s side of the dash – accessed by opening the door and flipping the end panel – I looked – no document.

This is when you start Googling the WWW for information about fuses and relays, locations and designations.

You’ll find diagrams, photographs, blogs, forums, but you won’t find which fuse in which of the four fuse boxes, protects the wiper motor.

You’ll start inspecting each fuse box in the hope of finding a clue or two – no.

Eventually you’ll come across a forum and a discussion about loose lock nuts:

The windscreen wiper is secured to an asymmetric linkage by a couple of shrouded nuts – with plastic caps.  Check them – you’ll probably find one or more is so loose you can turn it with your fingers…  🙂

Tighten and away you go – you could use LokNut and or a spring washer to reduce the chances of it happening again, but do not over tighten it.

Cheers…..

Advertisements

One thought on “Mercedes Benz CLS 350cdi Grand Edition 2010 [model W219] – windscreen wiper stopped / not working.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s